From f87ea24a821c1cee8f9a8f0d38d7f02fa43d8383 Mon Sep 17 00:00:00 2001
From: Danny Milosavljevic <dannym@scratchpost.org>
Date: Mon, 7 Jan 2019 20:01:34 +0100
Subject: gnu: Add docker.

* gnu/packages/docker.scm (docker): New variable.
* gnu/packages/patches/docker-engine-test-noinstall.patch: New file.
* gnu/packages/patches/docker-fix-tests.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add them.
---
 .../patches/docker-engine-test-noinstall.patch     | 23 ++++++++++++++++++++++
 1 file changed, 23 insertions(+)
 create mode 100644 gnu/packages/patches/docker-engine-test-noinstall.patch

(limited to 'gnu/packages/patches/docker-engine-test-noinstall.patch')

diff --git a/gnu/packages/patches/docker-engine-test-noinstall.patch b/gnu/packages/patches/docker-engine-test-noinstall.patch
new file mode 100644
index 0000000000..85d56a3465
--- /dev/null
+++ b/gnu/packages/patches/docker-engine-test-noinstall.patch
@@ -0,0 +1,23 @@
+Last-Update: 2018-06-18
+Forwarded: not-needed
+Author: Dmitry Smirnov <onlyjob@debian.org>
+Description: prevents test-time installation that causes FTBFS.
+~~~~
+ go test net: open /usr/lib/go-1.10/pkg/linux_amd64/net.a: permission denied
+~~~~
+
+--- a/hack/test/unit
++++ b/hack/test/unit
+@@ -18,12 +18,8 @@
+ 
+ exclude_paths="/vendor/|/integration"
+ pkg_list=$(go list $TESTDIRS | grep -vE "($exclude_paths)")
+ 
+-# install test dependencies once before running tests for each package. This
+-# significantly reduces the runtime.
+-go test -i "${BUILDFLAGS[@]}" $pkg_list
+-
+ for pkg in $pkg_list; do
+     go test "${BUILDFLAGS[@]}" \
+         -cover \
+         -coverprofile=profile.out \
-- 
cgit v1.2.3