From eb9d36670277f2206f87f50fa5186c482aa7fa12 Mon Sep 17 00:00:00 2001
From: Kei Kebreau <kkebreau@posteo.net>
Date: Mon, 18 Jan 2021 17:52:13 -0500
Subject: gnu: libmad: Add comment justifying the 'install-pkg-config phase.

* gnu/packages/mp3.scm (libmad)[arguments]: Add a comment about Audacity
requiring a pkg-config file for libmad.
---
 gnu/packages/mp3.scm | 4 ++++
 1 file changed, 4 insertions(+)

(limited to 'gnu/packages/mp3.scm')

diff --git a/gnu/packages/mp3.scm b/gnu/packages/mp3.scm
index c32b3cba11..916aa3e3b3 100644
--- a/gnu/packages/mp3.scm
+++ b/gnu/packages/mp3.scm
@@ -82,6 +82,10 @@ (define-public libmad
             ;; remove option that is not supported by gcc any more
             (substitute* "configure" ((" -fforce-mem") ""))
             #t))
+        ;; Normally one should not add a pkg-config file if one is not provided
+        ;; by upstream developers, but Audacity expects a pkg-config file for
+        ;; this package, and other major GNU/Linux distributions already provide
+        ;; such a file.
         (add-after 'install 'install-pkg-config
           (lambda* (#:key outputs #:allow-other-keys)
             (let* ((out (assoc-ref outputs "out"))
-- 
cgit v1.2.3