From c4230cda090b8a4d96c195173f968c7a603d6d36 Mon Sep 17 00:00:00 2001
From: Rouby Pierre-Antoine <pierre-antoine.rouby@inria.fr>
Date: Tue, 15 May 2018 15:24:42 +0200
Subject: gnu: Add go-github-com-jpillora-backoff.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/golang.scm (go-github-com-jpillora-backoff): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/golang.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

(limited to 'gnu/packages/golang.scm')

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 01e59983fe..e4caf82562 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1385,3 +1385,29 @@ (define-public go-github-com-hashicorp-go-version
 a collection of versions properly, handles prerelease/beta versions, can
 increment versions.")
       (license license:mpl2.0))))
+
+(define-public go-github-com-jpillora-backoff
+  (let ((commit
+         "06c7a16c845dc8e0bf575fafeeca0f5462f5eb4d")
+        (revision "0"))
+    (package
+      (name "go-github-com-jpillora-backoff")
+      (version (git-version "0.0.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/jpillora/backoff.git")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0xhvxr7bm47czdc5hy3kl508z3y4j91i2jm7vg774i52zych6k4l"))))
+      (build-system go-build-system)
+      (arguments
+       '(#:import-path "github.com/jpillora/backoff"))
+      (home-page "https://github.com/jpillora/backoff")
+      (synopsis "Simple exponential backoff counter in Go")
+      (description "This package is a simple exponential backoff counter in
+Go.")
+      (license license:expat))))
-- 
cgit v1.2.3