From c9730b7029087995a748e6c04dd810d7517fa966 Mon Sep 17 00:00:00 2001
From: Efraim Flashner <efraim@flashner.co.il>
Date: Thu, 23 May 2024 14:02:32 +0300
Subject: gnu: glade3: Build with gjs on more architectures.

* gnu/packages/gnome.scm (glade3)[inputs]: Use gjs as an input on
architectures where it is supported.

Change-Id: I6d6596045b7a3f0dc22207350b353fcd82961958
---
 gnu/packages/gnome.scm | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)

(limited to 'gnu/packages/gnome.scm')

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d18c256d62..a3b9799209 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3266,9 +3266,8 @@ (define-public glade3
               (setenv "DISPLAY" ":1"))))))
     (inputs
      (append
-      ;; GJS depends on Rust, which is x86_64-only so far, so remove the GJS
-      ;; dependency on other platforms (FIXME).
-      (if (target-x86-64?)
+      ;; GJS depends on Rust so remove the GJS dependency on other platforms.
+      (if (supported-package? gjs)
           (list gjs)
           '())
       (list gtk+ libxml2)))
-- 
cgit v1.2.3