From ef2a3871fdebb5aa2b34fefbeec8d7be92e6097e Mon Sep 17 00:00:00 2001
From: Marius Bakke <marius@gnu.org>
Date: Sat, 27 Jun 2020 10:32:48 +0200
Subject: gnu: GDB: Inline cross-compilation fix.

* gnu/packages/gdb.scm (gdb-9.1)[arguments]: Remove conditionals on
%CURRENT-TARGET-SYSTEM.
---
 gnu/packages/gdb.scm | 12 +++---------
 1 file changed, 3 insertions(+), 9 deletions(-)

(limited to 'gnu/packages/gdb.scm')

diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 38e45b14e5..338b73aa58 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -70,20 +70,14 @@ (define-public gdb-9.1
                      #t))
                   (add-after
                    'install 'remove-libs-already-in-binutils
-                   (lambda* (#:key inputs outputs
-                             ;; TODO: Inline the native-inputs addition and
-                             ;; below usage in the next rebuild cycle.
-                             ,@(if (%current-target-system)
-                                   '(native-inputs)
-                                   '())
+                   (lambda* (#:key native-inputs inputs outputs
                              #:allow-other-keys)
                      ;; Like Binutils, GDB installs libbfd, libopcodes, etc.
                      ;; However, this leads to collisions when both are
                      ;; installed, and really is none of its business,
                      ;; conceptually.  So remove them.
-                     (let* ((binutils ,@(if (%current-target-system)
-                                            '((assoc-ref native-inputs "binutils"))
-                                            '((assoc-ref inputs "binutils"))))
+                     (let* ((binutils (or (assoc-ref inputs "binutils")
+                                          (assoc-ref native-inputs "binutils")))
                             (out      (assoc-ref outputs "out"))
                             (files1   (with-directory-excursion binutils
                                         (append (find-files "lib")
-- 
cgit v1.2.3