From 1e0e94c35e5f0d803f5ef2119338fbe0370f978d Mon Sep 17 00:00:00 2001
From: Philip McGrath <philip@philipmcgrath.com>
Date: Wed, 18 May 2022 14:11:07 -0400
Subject: gnu: Add elm-project-metadata-utils.
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

* gnu/packages/elm.scm (elm-project-metadata-utils): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
---
 gnu/packages/elm.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

(limited to 'gnu/packages/elm.scm')

diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index 4120fcaaf4..48594613f3 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -372,3 +372,28 @@ (define-public elm-parser
 library provides a coherent alternative that handles more cases and produces
 clearer code.  It is focused on simplicity and great error messages.")
     (license license:bsd-3)))
+
+(define-public elm-project-metadata-utils
+  (package
+    (name "elm-project-metadata-utils")
+    (version "1.0.2")
+    (source
+     (elm-package-origin
+      "elm/project-metadata-utils"
+      version
+      (base32 "1wj7chfy4knwwyc3k0hy431c80hs7hc686qsr34ayn8gip73x2jj")))
+    (build-system elm-build-system)
+    (propagated-inputs
+     (list elm-parser
+           elm-json
+           elm-core))
+    (home-page
+     "https://package.elm-lang.org/packages/elm/project-metadata-utils/1.0.2")
+    (synopsis "Work with @file{elm.json} and @file{docs.json} files in Elm")
+    (description
+     "This package is meant for people creating Elm tooling, like editor
+plugins.  If you just want to make stuff in Elm, there is nothing here for
+you.")
+    (properties '((upstream-name . "elm/project-metadata-utils")))
+    (license license:bsd-3)))
+
-- 
cgit v1.2.3