From df2dc0c41644477c8cc3ccc958b822f8440114ef Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Tue, 5 Apr 2022 18:35:14 +0200
Subject: gnu: pigx-scrnaseq: Set NUMBA_CACHE_DIR.

This is needed since the update of python-loompy.

* gnu/packages/bioinformatics.scm (pigx-scrnaseq)[arguments]: Rename
'set-PYTHONPATH to 'set-additional-environment-variables and set
NUMBA_CACHE_DIR.
---
 gnu/packages/bioinformatics.scm | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5ca1104436..e9778831d2 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11145,8 +11145,11 @@ (define-public pigx-scrnaseq
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-before 'configure 'set-PYTHONPATH
+         (add-before 'configure 'set-additional-environment-variables
            (lambda _
+             ;; Needed because of loompy
+             (setenv "NUMBA_CACHE_DIR" "/tmp")
+             ;; Needed to capture environment
              (setenv "PYTHONPATH" (getenv "GUIX_PYTHONPATH")))))))
     (inputs
      (list coreutils
-- 
cgit v1.2.3