From 5defad2b7c2907649893c1c2073849a80dc381f2 Mon Sep 17 00:00:00 2001
From: Ricardo Wurmus <rekado@elephly.net>
Date: Sat, 24 Sep 2022 14:15:56 +0200
Subject: gnu: Add pybind11-2.3.

* gnu/packages/python-xyz.scm (pybind11-2.3): New variable.
---
 gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ffcb023d60..54ed7fefed 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22421,6 +22421,26 @@ (define-public pybind11
 inferring type information using compile-time introspection.")
     (license license:bsd-3)))
 
+;; This is needed for python-vaex-core.
+(define-public pybind11-2.3
+  (package
+    (inherit pybind11)
+    (name "pybind11")
+    (version "2.3.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/pybind/pybind11")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "11b6dniri8m05spfd2a19irz82shf4sdca73566bniggrf3zclnf"))
+              (file-name (git-file-name name version))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments pybind11)
+       ((#:tests? tests? #false)
+        #false)))))
+
 (define-public python-pooch
   (package
     (name "python-pooch")
-- 
cgit v1.2.3